Start a new topic

Starcraft II can't be detected!!

Have same problem with

Can't add it manually.

Didn't find any executable for Starcraft II in chosen dir.

Even locating the directory and SC2.exe or executable SC2x64.exe the Raptr does not accept add the game Starcarft II he gives the following error: unable find game executable in directory you have chosen.


2 people have this problem




Login to post a comment

Same problem with me. Starcraft 2 is not automatically detected by the client. If I try to manually add the game the game exe is not detected!

But when playing Starcraft 2 the client detects that I play the game. But it was not tracked in my profile.

Please help with the game!

@pooomukkel - Have you tried reinstalling Starcraft II at all?

Yes. But still no detection for the game...

Confirmed.
Problem still persists.

Starcraft II 3.5.3.45737 cannot be added to library manually.

@glebhappy - I just checked again and Starcraft II is detecting according to both QA and my own results. If you're still having this issue, I highly recommend making a ticket with logs attached so we can investigate. 


To send logs you just right-click on the Raptr taskbar icon, select Help > Feedback, fill out the info and make sure the checkbox is selected. Post back here to let me know you have sent it.