Start a new topic

AMD Gaming Evolved looks for the wrong .exe for Armoured Warfare

The AMD Gaming Evolved App looks for "mycomgames.exe" which is not the correct .exe for Armoured Warfare, at least for the NA and probably EU version as well. The correct .exe should be the "armoredwarfare.exe" that is located in both the bin32 and bin64 folders. I have attached some pictures below:

AMD Gaming Evolved App Manually add game

^AMD Gaming Evolved App Manually add game


bin64 folder

^bin64 folder


bin32 folder

^bin32 folder






Login to post a comment

Та же столкнулся с данной проблемой, почему понимаю НЕ  именно "mycomgames.exe"   когда должно быть  "armoredwarfare.exe" 

Ей у? Разработчики. За три месяца не можете исправить ошибку? ИЛи добавить второе имя файла?

We have the detection set that the launcher is named MyComGames.exe and the actual exe for the game is "armoredwarfare.exe".


Can you verify that the launcher name is incorrect?

So with just the My.Com Game Center running this is what it looks like:


I got to that by right clicking on where it says "MY.COM GAME CENTER (32-bit)" and selecting "Open File Location."


However when I have Armoured Warfare running and do that same thing but this time selecting where it says "Armoured Warfare" in task manager this what it looks like:

This leads me to believe that the .exe for the 64-bit version of the game to be the armouredwarfare.exe located in the game bin64 folder and that the "MyComGames.exe" is the name of the .exe for the My.Com Games Center application.


You can also test this out for yourself and see if you get the same results and I can also show this process with a video and link said video here if preferred.




@kourgath223 - Correct. A lot of games open with a launcher, and we get detections for both. 

For instance, Final Fantasy XIV has a launcher exe of "ffxivboot.exe". However the detection for the actual exe is "ffxiv_dx11.exe". The launcher exe is important because it helps guide to the registry key (if the game has a launcher that is).


Looking at your images, it does appear that "MyComGames.exe" is the launcher, and "armoredwarfare.exe" is the game. Did you try going to the MyComGames.exe when trying to add it manually?

I just tried using the "MyComGames.exe" for the first part and then it asked me to find the "armouredwarfare.exe" located in either the bin64 or bin32 folder and it worked I think the reason I thought it was looking for the wrong .exe was because:

1) I never paid attention to how AMD Gaming Evolved looked at launchers

and

2)Because the "MyComGames.exe" is not located under Program Files or Program Files (x86) but rather it is located under OS Drive letter (C: in my case)/User/Windows Username/AppData/Local/MyComGames


And now it works and I see Armoured Warfare working like all the other games that have been detected by AMD Gaming Evolved.


 

Glad to hear it! Let me know if you have any other problems, or questions.

Hey Verun ! I want your help My raptor detected the fake launcher of watch dogs. What should I do to add the correct one ?

Hey faizan20000, 


I guess I'll have to get more info. What do you mean by the fake launcher for Watch Dogs? Can you provide me more details? Thanks! :-)