Start a new topic

Unknown settings in World of Warships

Hi, I try to optimize World of Warships so I click the "Optimize" button then Gaming Evolved tells me "Your game is now optimized" and the game has a green circle. Done right? Uhm.. no. When I select an other game from the list or change a tab for instance back to "Home" the game's settings are been restored to default with a yellow triangle and the "Current Settings" are Unknown. I tried reinstall the game, run it as admin, change installation's destination, play it in window mode etc... nothing is changing. I have no problems with other games. What's going on?

2.jpg 2.jpg
106 KB
1.jpg 1.jpg
107 KB

1 person has this problem




Login to post a comment

We just tested the optimization for World of Warships and it does appear to be work. However, it seems like we're not able to find the config file for the game (it's not uploading in attachment to your account). Have you changed anything in regards to the where the game is installed? Got a new boot drive? Anything like that?

No I hadn't changed anything before this issue appeared. After that I tried to uninstall the game and reinstall it to a different location (actually in another hard drive). Also I deleted the game from Gaming Evolved's list so that it will snan and optimize it again but nothing is changed.

Would you be able to look in your World of Warships install location and check for 'preferences.xml' to see if you have it?

https://gyazo.com/d5eb90747f51aaa002417491d996775c


If you do have preferences.xml, you'll want to try resetting your some files in your raptr appdata folder. 

1. Close down Raptr/AMD Gaming Evolved application.

2. Hit the Windows Key + R and type in '%appdata%' without the quotations. 

3. Go into the Raptr folder. Then go into the "data" folder.

4. Find these 2 files and remove them (either move to another folder/desktop or delete them): https://gyazo.com/d7219a0c3382c275bf1f4dd324bb21d7

(game_detection_pc.json  and  installed_games2.dat)

5. Open the Raptr client again and rescan for games/check optimizations.

(Keep in mind doing this step will negate all optimizations, so you would have to redo them)




I do have 'preferences.xml' in game installation's folder. I also had tons of 'preferences.raptr_14xxxx.xml' files which I deleted cause I guess they were created everytime I was clicking 'Optimize" button. Then I closed down GE and I went to the 'appdata' folder you pointed me and I deleted 'game_detection_pc.json' and 'installed_games2.dat' files. But when I reopened GE I didn't have to optimize again my games like you said and the problem with WoW is still there. (note that indeed GE started checking for updates and for installed games when I opened it, like it would do if I installed it for the 1st time).

Would you feel comfortable looking into your registry?

You would have to open "regedit" (Windows Key + R > type in 'regedit')

And then follow this string:

HKEY_CURRENT_USER/Software/Wow6432Node/Microsoft/Windows/CurrentVersion/Uninstall/{1EAC1D02-C6AC-4FA6-9A44-96258C37C814na}_is1/


After that, let us know in the "Install Location" file where it is pointing to.


If you would rather avoid putting any type of personal information on this public forum, I can convert this forum post into a private ticket before you post where the game is located on your drive. Let me know.

I don't have 'Windows' folder inside 'HKEY_CURRENT_USER/Software/Wow6432Node/Microsoft/' hmm... There is only one folder called 'Active Setup'


I have installed WoW in a partition of my main HDD with the letter D so the location is D:\World_of_Warships\


PC Specs

OS: Win10 Home x64

CPU: i5-760

RAM: 8GB

GPU: MSI R9 270 2G

My bad, Registry string error >_<


Here is the actual string:

HKEY_CURRENT_USER/Software/Microsoft/Windows/CurrentVersion/Uninstall/{1EAC1D02-C6AC-4FA6-9A44-96258C37C814na}_is1/

(Removed 'Wow6432Node')


Let me know the results, thanks for replying and sorry for the dumb mistake!

No problem, thank you for your time. :)



^ I didn't mean that the issue has been solved. Sorry if there was a misunderstanding.

@p4n0s86 - I understand :-)

Is it safe to say that World of Warships is installed in that location on your D: Drive?

Yes I have the game installed in a partition of my main HDD which I created specifically for games and the exactly location is "D:\World_of_Warships\". I have tried to reinstall the game in C:\ without "_" or "spaces" in the folder's name without luck. I'm not sure and maybe I'm wrong but I think this issue started since I have installed the new AMD's Crimson Driver.

That would be very odd if Crimson Drivers were interfering with it, although I wouldn't be too shocked. I'll convert this Forum post into a ticket and then request logs from you. I'd like to look into this a bit deeper. 


Ticket #25737 for your reference

I'm having this same problem, I've tried deleting the files, the install directory should be default, I didn't change it.  Just wondering if anything has come about since this was last looked at.

 

@kraikof - Which setting is it for you?