Start a new topic

Overwatch CBT

When playing Overwatch the overlay for recording appears but when pressing the hot keys to try and record nothing happens.  Have tried Full Screen / Full screen windowed / Windowed  etc.





Login to post a comment

I believe we are aware that Overwatch is having issues since it's latest beta installment. We are working on a solution and should have it corrected soon. Sorry for the inconvenience.

Can confirm this***

I was just coming here to post this.


A bit of troubleshooting I can offer is that when I click the 'Launch' button in Raptr to launch Overwatch, all it does is bring up my Battle.net and it doesn't launch the game.

I suggest looking into correcting which exe's are triggered by the launch button, and confirm they are correct, because I think they may be backwards. 


The "Overwatch Launcher.exe" only launches the Battle.net, 

The "Overwatch.exe" actually launches the game. 

@kfr - Oh yeah. We're very aware. 

Making that change was very simple. However there was an .dll issue that needed correction. We have been doing testing for it and it appears like our fix is working. We should be rolling it out with a client update next week. Thanks for your patience!

 @Verun Hey, its now 7 days later. Is the update out already or are you still fixing it? :)

@d35t1201 - Haha go figure. The release got pushed back again to fix a few more things. More than likely Monday (Feb 29th), but it's still subject to change. Sorry for all the delays, but we appreciate you guys waiting around!

It's now 5 days past, I've reinstalled Raptr and it appears to still not work. I converted already, this past year, to intel CPUs and I'm quickly approaching buying a 980 just so I have Shadowplay. They seem to have their product working over there. 

Plays.tv client updated yesterday and it should be recording Overwatch now.