Start a new topic

As a Gameplay footage recorder these are some major issues I have with Raptr

 I just started recording Gameplay footage as a part time thing so I never really cared about how the recording software worked with AMD cards and after a month of using Raptr I have a few gripes with it that will probably force me use a different recording software or just switch to NVIDIA. And this is coming from a lifelong AMD fan...I have exclusively purchased AMD/ATI cards for the past 15 years. I have a r290x and before that I owned Two HD6970's so yea...big fan!


1. Raptr refuses to record gameplay unless I have Session VIdeo turned on. I don't know if its me...but thats how it works for me. I have tried many many times having it turned off and then using my hotkeys ingame to start/stop manual record, turn off/on Video capture and capture highlight. Nothing gets recorded unless I have Session Video turned on...which is really bad...because then I'm forced to record as soon as I start a game which leads to HUGE file sizes


2. Raptr doesn't work with some games. Specifically for Blade and Soul its hit or miss. I would say over 50% of the time when I start Blade and Soul Raptr just refuses to record and I am forced to quit the game once it loads up and I don't see the overlay. Then I need to exit Raptr and restart it and hope that it works. Once I confirm it works it will record up to where I select my character fine. When I go to log in it will record me loading,...then the overlay just disappears sometimes and stops recording. And again I have to exit the game and restart raptor...it's becoming quite a chore doing this everyday. Also for Black Desert I couldn't get Raptr to work at all.





Login to post a comment

Hi shyber, let me see if I can't help with some of your issues. 


1. You are correct, and that is an issue. However, we're already making changes to the recording portion of Raptr, so this should get corrected soon enough.


2. Blade & Soul comes up a lot, but we have been unable to recreate any problems with it. Do you notice anything specific about it when it doesn't work? Are you using any other 3rd party programs to hook into the game (MSI Afterburner, Overwolf, etc)?

When I play Blade and Soul I have no 3rd party programs or overlays that hook into the game. I just have Raptr and the game running.


When I first start the game Raptr overlay usually doesn't show up meaning nothing is being recorded. When I see that the overlay isn't on I will exit the game and I have to restart Raptr to get it to work. Once I get Raptr to work it works fine until I log into the actual server. Once I choose my character and the map loads it will load up and again the overlay just turns off while the map is loading which forces me to again exit the game and restart. When I check my recording its the same thing...it records me selecting my character clicking connect....then it shows me loading the map and then the recording just stops.


Basically it generally it takes me three restarts of Blade and Soul and one restart of Raptr to be able to record properly.

Sounds like I may need to see logs to figure out what is happening and why it is stopping the recording. Are you playing on the US/EU version of Blade & Soul?

 I am playing on the US servers.


So theres a different issue now but this one is on NCsoft. They just released a patch yesterday and re-enabled Game Guard. If I have Raptr recording the game will shutdown as soon as I enter my pin and give me an error. As of now I can only play if I have recording turned off...but other then that Raptr still is a hit or miss whether it actually records the game or not. How do I send a log??

Go to this link: http://support.raptr.com/support/home

and "Create a New Ticket" at the top of the page. Once it has been created (and you're welcome to link this forum post) reply back here and let me know so I can grab it when I can. I'll provide instruction on how to attach logs from there.

sorry its been a while since I posted on this thread. I tried out OBS for a few days and it worked out well for me since I could actually record when I wanted...even though the quality wasn't as good obviously.

I tried out the new playtv when it came out and I really liked it since I could turn off session videos and record when I wanted...huge improvement. Unfortunately...this only lasted 2 days because now Play.tv keeps giving me an error and I can't seem to record.

Although its a big improvement I still have the same issues...which is getting my software overlay to work with Raptr. As I mentioned before Blade and Soul is still a hit and miss

 

@shyber - Which error is appearing?

 I was originally getting an error that said Play.tv was already running and I couldn't record because of that. I uninstalled and reinstalled Play.tv and the issue has been resolved.


On another quick note...does Play.tv do something different when it records now? My C drive has always had 12GB of free space but now I am at 8.88Gb and the only thing that has changed on my system is updating the AMD drivers with the new Play.tv


I have my recordings setup to go to my D: drive but after I do a few recordings my C: drive is just filling up for some reason




Check your Temp Recording File location. I believe it defaults to C:/

the thing is I have my temp Folder set to my D drive same as my recordings.
Ugh since my post I recorded 2 videos and I am now at 8.57GB. Is there any way to find out what is being written onto my C drive?

You could send in a ticket with logs. That would allow me to see if it's writing anything to your C:/


You can do this by right-clicking on the Taskbar icon, Help > Feedback and fill in the information (make sure the checkbox is selected as well). Post back here when you've done this so I can look for it.

 Ok I will do that. Should I do a recording and then hit feedback?

Correct. Recreating it first can help me find the issue quicker since it's more recent.