Start a new topic

Huge frames drops while using raptr in PlanetSide 2

Hey there,


so I just set up my PC with windows 8.1 today from win 7 (installed all drivers, deleted the shitty ones that windows update automatically installs with display driver uninstaller).


So after installing my usual programs (browser, inet security etc) I installed PlanetSide 2, which is my main game since 2 years already. Since I like to record my gameplay and save some nice moments I always used raptr to record special moments (I only use the highlight function). Though after installing raptr I got some huge fps drops ingame.


Without raptr I get around 150 to 220 frames and with raptr I only get 80 to 120 frames at the exactly same spot and my frames are really unstable dropping from 120 to 80, then 60 and back up to 120ish. I tried to set the recording settings to potato, which means (480p, 15 fps and 5 mb/s). After that I got almost no frame drop ingame, which is weird, though recording with that doesn't work, since it will look kinda aweful.


With my usual settings (1080p, 60 fps and 25 mb/s) I get those huge drops and I have no clue how to fix them :/. I tried obs plus quick sync, though I get some frame drops there too, which are even worse, than the ones raptr provides me. I really don't wanna skip the recording part, since I really like to share my content on my YT channel. Any clue what could be wrong? I disabled all unnessecary programs, while running PlanetSide 2, though no difference and buying an nvidia card isn't an option, since I don't wanna buy a new GPU again, cause my current one is only 1 year old and works alright.


With win7 I had less frame drops, though some too, which weren't that bad though. I already installed all windoes updates that where available, including the service pack 1 for windows 8.1.


My rig:

MOBO: Asus z87-k

CPU: Intel i5 4690k @ 4,5 GHz

GPU: MSI Radeon R9 270X
RAM: Corsair 8 GB RAM
Harddrive 1: SanDisk SSD 240GB (PlanetSide 2 on it and Windows 8.1)
Harddrive 2:Western Digital 1TB HDD
PSU: BeQuiet 550W




Login to post a comment

Any chance you're running Crossfire configuration?

Does it seem like it's only Planetside 2 having the problem?

You may want to send in a ticket with new logs as well.


To send logs you just right-click on the Plays.tv taskbar icon, select Help > Feedback, fill out the info and make sure the checkbox is selected. Post back here to let me know you have sent it. 

No, I don't run crossfire, only a single R9 270X from MSI. I haven't cehcked other games yet since I don't have any installed apart from PS2. I will let you know after I check it out. Logs sent with two pics showing my frames, with and without raptr at the same place. Gonna attach them to this comment too.

 


Since I can't find an edit function I will reply again, cause I forgot something that I wanted to add. In terms of testing other games; a friend of mine is playing PS2 as well on windows 8.1 64 bit with an AMD card an has no drops what so ever, so it seems like that it could be my rig, though I don't know what could cause those framerate drops.

 

Update: I tested Raptr with The Witcher 3 and without I get 40 to 45 frames and with Raptr enabled I get 29/30 fps :/ Same place again, just started a new Hearts of Stone game and checked the frames where you spawn.

 

Today I tried my old GPU, which is a R7 265. Same problem aswell. Good frames without raptr, around 140 and with raptr only 65-70 frames at the same place. Gonna try out win10 and see how it goes.

 

Update: I installed Windows 10 Pro 64 Bit and the frame drops are significantly less than on Windows 8.1. Only around 10-20ish which is due to 60 FPS recording I suppose. I should be able to work with that. Guess that 60 FPS recording still needs some optimization. Thanks for that help regardlessly and keep up the good work!