Start a new topic
Solved

Purchases stuck at processing

Hi, 

I am unable to make any purchases in the raptr reward store. All purchases get stuck at processing


13 people have this problem




Login to post a comment

Thanks for the heads up.

We're looking into this issue currently.

Thanks bud. :)


No rush though. Looks like you guys have your hands full with the all the new changes.


Good luck with the overhaul!

Hello, I am trying to get the Dragon Age in-game thingie for 500 RP, but keep getting stuck at "Please wait while your order is being processed. Completed orders will display on the Past Purchases page." 

I've successfully bought a sweepstakes entry in the past, however now I'm not sure what's happening.

Just worried about that fact that it says it's limited, worried about missing the chance to buy it.

 We're looking into this issue currently Turbare, hang in there.

Stuck for me as well :(

I'm having the same issue, I have tried on 2 different computers using Chrome and Firefox and on my phone, still no dice.

 

Add me to the list. Had a ticket open for this issue for a week or so now, no reply.

Yes I am having the same issue as well. It just hangs at processing your order no matter where I try it. Client is updated to the newest version says 4.2.5.0 in the folder

 

Also having this issue last time I was able to purchase the silver sweeps was on Nov 8th tried every week since and no luck. I have not logged a ticket since I have seen so many others with the same problem.

 

Been having this problem for 2 months, nobody explained why it's still happening btw

i also have the same issue

Same issue here, made a ticket asking if support can just purchase it for me. So far no responce.

 Still no change here either. I am going to open a ticket tonight when I have some free time. I think we all have to for this to get fixed.



I went ahead and submitted a ticket on this as well, maybe if enough people do so they will assign it a greater priority in getting it resolved.