Start a new topic

Forced Software Encoding

i5-3570k, 16GB RAM, HD7950

Windows 8.1 Pro x64

Raptr v4.2.5 (build 90154, overlay r90151)

Any game


Forced software encoding. No matter what I have in settings

Everytime I am recording video using Raptr or playing game while Raptr's replay is on, process raptr_encoding_server.exe starts. And this process takes 25% of CPU time. That's kinda strange, because earlier I did record videos with raptr without FPS drops or even freezes. Now I have HUGE shuttering Why did software encoding suddenly turned on? In preferences I haven't checked "Use software encoding" option. (In fact, it is grayed out and I can't change it. So, Raptr mustn't use software encoding). Then I decided to check config file (which is in %appdata%/raptr/data). And, of course, in config software encoding was forced with string "gamedvr_use_software_encoder = true" I have edited the file, marked it as read-only, but that didn't help

WTF? What should I do to be able to record videos without additional CPU load, as it was some time ago?



1 person likes this idea




Login to post a comment

That is strange.

Typically that's only enabled when we benchmark your system and find that we can't do it using the videocard VCE.

Can you try this:

Close Raptr

Press the windows key +r then type %appdata%\Raptr

Find your Raptr.cfg file

Rename it to old_Raptr.cfg

Restart Raptr

This will treat you like it's your first time signing into Raptr, so you'll need to sign back in to any connected accounts and change any settings you previously had.

Unfortunately, it didn't work.


And new raptr.cfg comes with string "gamedvr_use_software_encoder = true" in both [deadmoroz14] and [guest%some letters%] sections


Maybe I should send you some logs? Just tell me what I have to do. Show logs of running a game, of clean restart (when my hardware is being detected) or whatever you need.

The forced software encoding is due to your computer, for whatever reason, not benchmarking.

Right click on the AMD icon in the system tray and select preferences.

Try unchecking it there.


The thing is that "Enable software encoding" isn't checked

I can't uncheck something that is already unchecked

Iin raptr.cfg value gamedvr_use software_encoder is set to true. WTF?

Can you nuke your config file? To do this:

1) Close down Raptr/AMD GE

2) Press the Windows key + R to get the run command box up

3) Type %appdata%\raptr and press Enter

4) Locate raptr.cfg

5) Delete this file (or rename it)

6) Restart Raptr/AMD GE 


This may result in Raptr treating you as a new user on this PC, so you will have to reinput some accounts into the Friends & Accounts widget.

I already done that (as you can see form posts 2 and 3 of this topic)


But OK, I did that again. Still encoder server is running.

Do you have "Record" and "Replay" enabled in the home screen?

Do you continue to see the CPU usage if "Replay" is disabled but "Record" remains on?

Yes, both Record and Replay were enabled


After disabling Replay encoder server is not running

But, of course, it is running after starting recording (ctrl+;)

Interesting. Does it do the same thing with Replay, but with Record disabled?


Lastly, can you recreate the entire event (preferably restarting Raptr) and then send in logs for us to take a look at?


To send to your log files:

1) Open the Raptr client

2) Right click on the Raptr icon in the system tray

3) Click on Help, then Feedback.

4) In the window that appears, check the box at the bottom (Send log file).

5) In the text box, please either describe the issue or paste the forum post for your issue.

6) Hit send.

7) Post back here when you have sent your logs.

(Note: Make sure that you quit out of any game you are in before you send in your logs.) 

Sent a log


>Interesting. Does it do the same thing with Replay, but with Record disabled?
The process Raptr Encoder Server appears in 2 cases:
1. I run a game with enabled Replay (doesn't matter if Record is enabled)

2. When I run a game without Replay but with Record and start recording a video. Obviously, if I'm not starting a video recording, there is no Encoder Server process


So, as I understand it, Encoder Server starts whenever I have to record video/replay. For some reason Raptr is using not my GPU, but CPU to record videos. Earlier I did record videos w/o additional CPU load. For me it looks like some kind of hardware detection/analysis problem

that's exact same problem with my raptr  as well! Hadn't been able to use raptr for about three months now because it refuses to use the gpu and instead uses the cpu for recording.


r9 290


Do you have MSi enabled? try turning that off