Start a new topic
Solved

Unable to purchase rewards

There seems to be an error after purchasing rewards. Tried multiple rewards but the same error occurred.

"Cannot complete order

Well darn. Looks like there may be something wrong with your account, please send an email to disqualified@raptr.com describing what it is you were doing and we'll get to it as quickly as we can!"







Login to post a comment

Looks like your issue was resolved! Thanks for letting us know though, have a great day!

I have the same problem :( Can you fix it for me too please?


Thanks /Johan

@svenne - Your account was placed in a moderated state for posting spam. I have gone ahead and undone the moderation on your account, however I would recommend that you refrain from posting further scam/spam/referral links in the future. 

Hi, I had the same problem yesterday but it has now been resolved. But today, when I attempted to purchase again, it said that I have already purchased the item even though I still had my 2000 points and my last purchase on record was in January. Is the limit one purchase per a month? If it is then please fix this. 

The limit is one per account. That is why you are unable to purchase the Smite 200 Gems (I assume that is what you're trying to get).

So 1 per account like for ever?

This is my purchase history.

Typically, there is a reset period, but it depends on the batches. For instance, the Smite 200 Gems has been the same batch since Jan. However we had a previous batch back in September (I believe). If you had purchased from the first batch in Sept, then you could purchase again in Jan/Feb. 


However, we have been told by Hi-Rez that the codes should only work one per account. So that is why we made the limitation. It was to avoid several users stating that they purchased a code and we're unable to use it based on Hi-Rez's limitation. 

Oh, ok when is the next batch?

Hmm, no idea honestly. Typically we wait til the current batch is out of stock and then see if Hi-Rez (or whatever partner is offering the product) wants to give out more. So don't really have an answer for ya. Sorry.

Ok, thanks for your help!

I have the same problem, Can you fix it for me too please?

@lMorenitoh - Your issue has already been resolved. Thanks for writing in!

Have the same problem :(