Start a new topic

Shadows of Mordor "Optimal" settings may be incorrect.

In Shadows of Mordor the "Optimal" setting for Texture Quality is "Ultra". This should be changed to "High".

The developers of that game only recommend that setting if your video card has 6GB of memory per GPU.

Most single GPU AMD cards do not have that. The 7990 has 6GB but it is split 3GB/3GB between 2 GPU's. The 295x2 is the same with 4GB/4GB split between GPU's. There is a new single 290X with 8GB but, I would guess that less than 1% of your users have that card.

Please change the Optimal setting for Texture Quality to "High".


Login to post a comment

I went ahead and talked to our Optimization and from the testings that they received on a card with 4GB they saw some fairly good results even with the Ultra Textures. Now, everyone's interpretations of what "Optimal" can be different. When recommending the Ultra Textures, we did not get 60FPS running smoothly (on an equivalent card) but for some users that is not a make-or-break factor. However, if some users require 60+FPS then they may want to go with different results, such as "Performance".

Have you actually tried the Ultra Textures to see how the game runs? Have you had any issues? Was there a part of it you didn't like? Let us know, we can adjust small things here and there but we'll want to know what to re-test.


Thanks for the response Verun.

I have tried the game with Ultra Textures enabled on an AMD FX8350, two 7950's (3GB RAM per card) in Crossfire and16GB Ram. There were some serious fps drops when turning or moving quickly though areas. Basicly when the game tries to load new textures.

I would like to give you some numbers but I can't get the Raptr FPS display to work with that game. I'm not sure what I'm doing wrong.


Shadows of Mordor must have given us some trouble, because its in-game overlay is not enabled by default. If you need to see FPS for it you could try to force enable the in-game (not recommended) or just try and get another FPS meter to use. If you can get me the numbers, I'll hand them to Optimization and we can figure things out.

I recorded two videos to show the choppiness of having the Texture Quality set to "Ultra". Both videos are recorded at 1080p. I would suggest watching them at that res so you can see the FPS numbers in the upper left corner. Once again my rig specs are AMD FX8350, two 7950's (3GB RAM per card) in Crossfire and 16GB Ram.

The videos are:
Texture Quality Ultra

Texture Quality High

Posting for notice. The forums didn't count my previous post as the last post.


I think I had to verify the post because it included Youtube links. 

However, watching the videos, you are correct. I definitely see a difference. I'll let Optimization take a look at these and see where they go with it.