Start a new topic
Solved

Can't Purchase Rewards

It just sits on "Processing" w/the red bars going back and forth for hours.  Tried multiple computers, different browsers, in the application.  Nothing works :( 


5 people have this problem




Login to post a comment

Same here, I wasn't able to get smite gems last time because of this, and it was about month or even more ago. Over week ago I submitted ticket, and guess what... I still wait for an answer. 

Oldest threads about this issues are month old, and got responses like "we're investigating the issue" but I guess a month is not enough, for such irresponsible company, to fix serious issue that affects only small part of users.

I am having the same issue. Attempted to buy SMITE gems with rewards points and am just stuck on processing. I too have sent a support ticket in and I have not had a reply. 

I am having the same issue. I sent a ticket as well and have heard nothing. 

The Processing issue is a very high priority for us to correct right now. We're sorry for the inconvenience, but we want to get it working as soon as we can.

It's been broken for like a month. Can I just get the code for my DA:I pack that I want to purchase? 


We have recently solved the current "Processing Issue" for users. Although we have tested this out with a few users with absolute success, we cannot account for every single user. You're welcome to purchase the rewards you have been wanting, but if you continue to have issues please let us know and respond back to this forum or create a ticket. We thank you for your patience.