Start a new topic
Solved

Dragon Age Inquisition Reward pack

Hi, I'm trying to redeem my gift pack for Dragon Age Inquisition and getting my order stuck at processing. I assume I have the requirements for it but can't tell what's wrong. Tried from the raptr app, the site via Firefox and Chrome and  my laptop still can't get it. Any ideas? Thanks very much in advance.


3 people have this problem




Login to post a comment

The Processing Issue is currently affecting some accounts which can prevent that user from purchasing any reward. We are currently investigating it and may have a fix soon. We'll do our best to keep users posted. 

We have recently solved the current "Processing Issue" for users. Although we have tested this out with a few users with absolute success, we cannot account for every single user. You're welcome to purchase the rewards you have been wanting, but if you continue to have issues please let us know and respond back to this forum or create a ticket. We thank you for your patience.