Start a new topic

Instant Replay Audio is AHEAD of video

I'm trying to use the GVR Instant Replay function to record BF4 footage. I previously couldn't get it to work at all, but it seems like a reinstall of the Gaming app fixed that, and it now functions (at least usually).


However, the resulting video clips consistantly have the audio out of sync with the video. The audio is about 1/2 to 1 second AHEAD of the video.  This desync is consistant from start to finish of the 1 minute replay videos.


Please advise on how to correct this.


I have resorted to shifting the audio with external editing software, but this is an added hassle, plus the shifted files seem to cause me problems with other editing software when I further edit the clips.


I need to get the Raptr replay vids working properly at the source.


12 people have this problem




Login to post a comment

Unfortunately, we currently don't have a fix in place, but we are aware of it and and retesting. 

Right now we're asking users to do the following if they are getting the audio desyncing issue:


  • Create a ticket regarding the issue and post the Ticket number here so we can take a look at it.
  • Recreate the issue of the audio desync and upload a video so that we can download a raw, unedited version of it. No Youtube uploads.
  • Send logs after making the video. Preferably even before uploading it.


To send to your log files:

1) Open the Raptr client

2) Right click on the Raptr icon in the system tray

3) Click on Help, then Feedback.

4) In the window that appears, check the box at the bottom (Send log file).

5) In the text box, please either describe the issue or paste the ticket number for your issue.

6) Hit send.

7) Post back here when you have sent your logs.

(Note: Make sure that you quit out of any game you are in before you send in your logs.)

I tried to upload a video showing that I too suffer from this problem, but I got another error: http://i.imgur.com/iw9mgf2.png

http://i.imgur.com/iw9mgf2.png

First time I tried GVR and I have the same problem.
I will stay with the nvidia's shadow play while it's not fixed.

I will add that playing it with vlc and trying to find the correct delay (tips: press J & K to change the delay) gave me approx 650ms advance on audio compared to video.
Probably a problem with the H264 buffer which freeze the images at beginning of every video.

For me, the necessary audio delay was around 300ms (that is the delay I used in AVIDemux to achieve synch)

I have the same problem, funny thing is Importing it into Adobe premier fixes it then just export it. Just thought I'd share for those that have it. I am sick of all the issues. 


DX11 is broken for me recording on 1440p screen and Mantle can only record 720p.


I can record 1440p 60fps Motion JPEG on other software but they don't have replay feature, I keep hopping you guys are going to get your shit together and have 1080p Mantle working. AMD told me moths ago it will be working before the end of last year. The amount of time and energy wasted is unbelievable!

Still the same on 4.3.5

@astrix_au - I went ahead and created a ticket so maybe we can figure out the audio delay, or at least keep you or us better informed to the current issue. Since the audio delay does not affect everyone, it would be interesting to possibly find what is going on with your system, or others.

on the previous version only replay was affected and manual recording wasn't, that is a big clue. I haven't tested manual recoding on 4.3.5, i'll do it later..

What software did you use to fix the audio/video sync, Adobe Premier Pro CC does it automatically when I import it no need to adjust. That is strange and might give a clue. 


I am using Mantle to record because DX11 isn't rendering the pixels correctly as you can see in the thread below. It was recording fine on my 1080p monitor just not at 1440p I tested them again and again to confirm, luckily Mantle never had this issue of recording from 1440p screen and saving the video to 1080p size due to 1080p limit..

http://support.raptr.com/support/discussions/topics/5000019124


My system specs are 

Rendering API: Mantle (because of the reason I stated above, plus the gameplay is way better when recording no lag at all on Mantle at 720p)

ASUS Swift PG278Q - 2560x1440p

4770K

Asus Maximus VI Formula

MSI R9 290X Gaming OC - crossfire

MSI R9 290X Gaming OC - crossfire

16BG Ram 1600Mhz

Ill share a raw video soon.

All tested on BF4 on Mantle API


I just tested manual recording on Mantle playing BF4 on 4.3.5 and it's not affected like 4.3.4 wasn't. Only the replay captured video are out of sync because the video starts after the audio.


Replay video: Out of sync

Manual recorded Video: In sync, looks good.


Importing replay into Adobe Premier Pro automatically fixes replays, plays in sync without any adjustments.

This time I also tried the importing the manual recording and it played correctly as well so on the manual recording Premier played it the same as VLC but replays differently than VLC, this might be a clue.


What is the best way to share a raw video?



I reduced the quality from 720p 50Mbps  to 10Mbps so it would be easier to share and the gameplay didn't feel as quick, obviously from the extra compression so it's better to use less compression.

Ticket Reference ID: 7027


I sent you guys the dropbox link to the video you requested by email.