Start a new topic
Solved

1440P SCALING ISSUE OF CAPTURED VIDEO ON DX11

Hi guys I have been using the my 1440p Asus Swift to record and have been having a major problem.

When the video scales it to 1080p it does it's wrong and the text and details are all jagged. I've used all other recorders and no other ones do this including bandicam (which can record even in 1440p Motion JPEG, it's VCE recording function scales it correctly to 1080p.

I use Mantle so I am happy as it should be working properly soon, at the moment there are major issues with stuttering and tarring.

The new Mantle recording from Raptr actually scales correctly so I am happy that you guys fixed that or simply never introduced it on the Mantle side.

I just tried DX11 again hopping it was fixed since it works correctly when recording Mantle even though the video is still useless as it's flashes and stutters, that will soon be fixed as it's only just been added so I'm looking forward to that.

Below are screen captures of the videos for comparison one for DX11 and one for Mantle.


DX11 1440p scaling:



Mantle 1440p Scaling:



Guys it would be great for you guys to finally fix it as it's been like this on DX11 for months.





Login to post a comment

Are you guys going to fix this issue? I've sent feedback logs again today.


It looks just like when I saved a video in Afterburner at 16:10 1050p by accident. Any lines going in 45 degrees from a right angle is jagged and not straight or smooth, so the number seven (7) would be pixellated. I've had this problem for ages and if it was ok I'd be able to record with DX11, I can't use Mantle as that can only record 720p and on a 1440p monitor that is too small. Mantle as you can see is fine but Mantle only records 720p correctly as 1080p is broken with major tearing and stuttering.

Have you seen this issue in other games, or only BF4?

Additionally, have you tested to see if you get the same results on other recorders as well?

I just tried BF3 and it has the same issue.


I can't record War thunder, Raptr does not track it, it can optimise it just doesn't have the onscreen display come up and can't record and raptr does track the game time.


I can't record Insurgency, when the yellow onscreen thing in the bottom right comes up the game goes into a sound loop and then I get error 109.Insurgency was just updated but I beleive it didn't work before the update either.


I wasn't able to record BF3 before but I realised MSI afterburner was causing issues and after closing it it records fine.

I finally got warthunder to track and record, it is also affected by the distorted pixels. I believe it's to do with the way DX11 records on a 1440p monitor. Mantle didn't have this bug introduced.

I could record properly when I had my 1080p monitor, but 1440p on DX11 when it resizes to either 720p or 1080p something happens. I can barely read the chat in BF3 and war thunder hurts my eye trying to read and look at the screen.


Below is how I got warthunder to finally work in raptr.

http://support.raptr.com/support/discussions/topics/5000036552

Should I create a ticket about this issue? This is a issue for people using 1440p monitor, thankfully when Mantle was released it didn't have this issue in BF4 but it does on DX11 in any game even BF4.


If I was to plug in a 1080p monitor it would record DX11 perfectly in 720p and 1080p. There must be something different between the way DX11 and mantle videos are saved from a 1440p screen.

I think it's got something to do with [16:9] crop or ratio on a 2560x1440p monitor, is there a difference the way DX11 and the new Mantle recording records 1440p screen?

Actually both mantle and DX recording are both 16:9... So it's not that.

I found something interesting that might be it, something in the format that separates DX11 videos from Mantle videos.


Every DX11 video has the following info:         Format settings, GOP : M=1, N=15

Every Mantle video has the following info:       Format settings, GOP : M=1, N=60


Could this be the reason DX11 isn't clear?

@astrix_au - Making a ticket about the issue would be a great idea. I would recommend letting us know what the ticket # is here so it won't get lost in the sea of tickets and I can get to it directly. I'll be honest and say that it isn't a top priority (since we have to resolve other issues like black screen, audio delay, as well as other things). But I'm sure we can get someone to take a look at it once things calm down a bit. 


But feel free and let me know what the ticket is so I can at least assign it to myself and follow-up.

I'm just going to have to use Bandicam for VCE, it doesn't have this issue on DX11, it can't do Mantle though.


You guys should inquire about their SDK might be with purchasing it. Then just add Mantle support and replay support. Although don't know if the SDK includes CVE, M-JPEG, CUDA, NVANC and external WVF but you guys should be able to afford it.

I created a ticket below and then sent feedback with logs and the ticket number.

http://support.raptr.com/support/tickets/7983

#7983 1440P RECORDING ISSUE ON DX11 ONLY, MANTLE API NOT AFFECTED


Hope this is a simple fix... 


Good luck guys, I really want to use Raptr but both DX and Mantle is broken for me :( Mantle is ok only for 720p but that is way too small.


This issue is still present when recording with DX11 on the latest version 4.3.6. 

Mantle is still not affected with this issue still which is great.

I'll do my best to respond back to your ticket. Thanks for making it. 

As an aside Astrix_AU I also run into this issue.  Any game I play at 1440p and record results in weird distortion and other odd issues in Raptr.  This shows up in both 720p and 1080p  (was hoping 720p would solve issues since 1440p is doubling, but issue remains.)