Start a new topic

Raptr GVR-In game not working with DX10 or 11 - BF4 anymore, does work mantle but flicking video

Was working perfectly fine with DX11 Battlefield 4 and Grid Autosport, iv'e deleted my raptr profile, uninstalled, reinstalled.


In game works with DX9 games.


Rig 

i7 4770k

R9 290

Z87 Pro

16GB 2133 Ram





Login to post a comment

When you state that GVR for Battlefield 4 no longer works, does it give any kind of error? 

When was it working fine for you?


Can you recreate the issue of trying to record and then send in your logs?


To send to your log files:

1) Open the Raptr client

2) Right click on the Raptr icon in the system tray

3) Click on Help, then Feedback.

4) In the window that appears, check the box at the bottom (Send log file).

5) In the text box, please either describe the issue or paste the ticket number for your issue.

6) Hit send.

7) Post back here when you have sent your logs.

(Note: Make sure that you quit out of any game you are in before you send in your logs.) 

Hi, Was the first time I used it and it was using DX11. Switched to Mantle and attempted to record with mantle but it does the recording but the video is skipping, its like someone is moving your screen up and down. Restarted PC, tried BF4 again with DX11 and Raptr wont activate anymore, it's only activating using Mantle and DX9 games. Iv'e tried re installing DirectX. Removing Raptr entirely, re-installed and same problem.

I get the flickering, but in Max Payne 3.

@djdynamite123 - Any chance you can provide a copy of the video showing the skipping with Mantle? Want to see if it's the same thing we've seen from others. 

VERUN yeah sure, here is a quick clip on youtube. https://www.youtube.com/watch?v=gwBuaTrSTrQ

Did you get it working?


I basically have the same set up: 4770K, 2x 290X and Asus M6F.


If your not using MSI afterburner or other software like that I guess my solution won't help. 

If I have it running it won't record BF4 on DX11 closing it fixes that issue. It must be a problem with both raptr and MSI afterburners RTSS both hooking into the BF4 game as RTSS displays on screen info just like Raptr but RTSS doesn't support Mantle thats why for me it wasn't a issue on Mantle.  

I guess other apps that also do on screen display support could be causing a issue just like the one I experienced with BF4 on DX11.

ASTRIX_AU, no iv'e tried with every program quit, it only works with DX9 games and Mantle, but mantle is recording with weird flicking. It use to work and then just stopped. Nothing changed on my PC, iv'e repaired/updated DX to no avail, iv'e deleted raptr folder in %appdata% and still no go. :*(

ok, the flickering issue is a bug that just about everyone is experiencing as far as I know on 1080p Mantle in fullscreen, mine used to look like yours but on 4.3.6 it's a lot less but still bad. Hopefully for you it's just a setting somewhere in Raptr that has disables DX11. I know in other recorders you can choose weather to hook each separately hopefully it's a settings that has been changed that Verun can pick up in the detailed logs and help you change. 



Iv'e not added any logs yet, what's the point if I cant even get raptr to activate during dx11 games?

The logs will tell them if DX11 is being activated and if not why.

Ok, sent in a log just now. Thanks

I can't get it to work either on BF4 DX11 either, it just doesn't have the on screen support so it can't record. On Mantle the on screen stuff comes on but nothing happens on DX11. It does say in the notification that you just ran BF4 but can't record.


I hadn't tried DX11 for a while as I have been using Mantle.

I tried BF3 DX11 and Raptr worked on that.