Start a new topic

No sound when recording gameplay

When I try to record any gameplay, for whatever reason the Replay function AND the normal record (GVR) don't record in game audio. They pick up my voice and the voices of friends in Razer Comms (kinda like TeamSpeak or Skype), but it won't record in game audio. I have it set to record "game sounds" in the settings, so I'm not sure why it isn't working. I have all audio devices disabled in my Sound/Recording section of Windows EXCEPT for my Microphone and my Speakers. At the moment I'm playing CS:GO, but I also have Black Ops 2, Battlefield 4 and Titanfall, and those videos don't have in game audio either. Just looking for a fix. Also, all of my "AMD Gaming Evolved" (Or Raptr) settings keep being reset every couple times I restart my computer or the program.

 


4 people have this problem




Login to post a comment

I have gone ahead and replied to your ticket. Hopefully we can figure out the issue. Ticket #18941 for your reference.

I am having this same issue. Tried to capture some footage of Mass Effect and there was no sound. Very frustrating.

 

@kutulu1 - I have replied to your ticket. We'll continue with the issue there. Thanks for letting us know.

I have the same problem. Only get footage without sound when recording black ops 2. have tried some other games tho and some of them worked.

@theo0019 - Does it only affect Black Ops 2?

Can you recreate the problem and then send in a ticket about it?


To send in logs, just right-click the Plays.tv icon in the Taskbar and select Help > Feedback. Input your information there and ensure that the checkbox is enabled. Post back here once you have done that so I can look for the ticket. Thanks!

@VERUN

Now i have sent in feedback. Thanks for answering

I have the same issue, there is no game sound or mic sound, i am using razor kraken 7.1 chroma. the weird thing that i used other headphones and they workt plzz help =)

I'm not sure if I got it working at the end but I think that U can set another microphone to listen to the kraken mic in windows and then mute it and select it in Raptr (or something like that) xD Hope it helped, btw go to properties on the other mic to enable it to listen to kraken mic. Sorry for english

@netflixghozzt - Check to see if you have a running process called KrakenHelper.exe (or something like that). Disable/Close it and then see if you're able to record audio.