Start a new topic

Capture function not working on The Witcher 3: Wild Hunt

 Will this ever be fixed, I saw some other guys on YouTube using fraps to record this game.







Login to post a comment

Hi, im newcomer to this forum and sorry for my lousy english, but I'll try to explain where is problem.

It is very strange that AMD GE by default doesnt work in Witcher 3. Actually AMD GE will recognize The Witcher 3: Wild Hunt and surprisingly will optimize the game, BUT video capture function or GVR doesn't work by default in Witcher 3 nor FPS display. 

Developers make lousy job over "hooking" overlay in AMD GE for Witcher 3.  

However there is a way to make GVR function run properly in Witcher 3. 

Install Dxtory (also another program for video capturing), run it, minimize it to taskbar, start AMD GE, run Witcher 3 and VOILA, AMD GE and GVR (video capture funciton) suddenly working in Witcher 3, and you'll be able to take screenshots or capturing video. 

Show FPS option doesn't work whatever you try. 

It is shame for AMD GE not working properly by itself in such brilliant and popular game. 


@boxerbih - Actually we do have it working. However, I am interested in your findings for those users who can't get it working. Keep in mind that everyone's PC is different and where one person cannot record, there could be tens of hundreds of others where it's working without issues. It's all about finding what specifically could be the issue about the user's PC that can help determine the solution.

@Verun

Sorry but I disagree about normal funcionality of AMD GE and GVR in Witcher 3 Wild Hunt. As we can see there are many questions in forum about how AMD GE and GVR does not work properly in Witcher 3. 

I don't know exactly what cousing that problems, but something isn't right with hooking overlay for GVR, not to speak about variable and not constant bitrate and fps of video capture file, also there is no FPS overlay. 

I'm playing Witcher 3 since June 2015 and each  new AMD GE with AMD drivers does not work properly in this game. 

Niether AMD Crimson 16.1.1., nor 16.1. and previous driver version and AMD GE with GVR does work in Witcher 3 byitself FOR ME.

Because AMD GE/GVR does not worked properly I looked for an alternative Dxtory, and accidentally found that  AMD GE/GVR suddenly work in Witcher 3 when working together with Dxtory. 

Im not using Dxtory, I use AMD GE video capture in Witcher, but Dxtory must stay in taskbar to work.  Also found AMD GVR works fine in Witcher 3 when working together with Overwolf (also video capture program). 

Maybe I am wrong, bu I assume  this indicates problem over hooking overlay. 

Tried MSI Afterburner, Dxtory and  Overwolf, they all works fine, recognize Witcher 3 and capture video, but AMD GVR/Raptr does not, and need another video capture program to work. Im using AMD GE GVR on my Sapphire R9 280X becuase it is good program for video capture and almost doesnt reduce the performance of my pc.

This is just my user experience. 

@boxerbih - That's very good to know. I can bring it up with our engineering team to see if they can make any sense of it. If you have not provided logs yet, I would recommend it since it may help us discover what is happening for your issue. It's very true that we cannot test every game with every possible GPU to determine specific issues. So it's possible that someone with a Sapphire R9 280X might have issues, where a R9 290 would run just fine. It's hard to determine all possible outcomes when there are this many variables. 


Either way, since you have been able to find a work-around, that is good. But I would be interested in getting logs from your PC after you try recording with only AMD GE, and then recording with Dxtory in the background. 


Best method to do this (while keeping your log information private) is to create a ticket and then alert me on this post that you have created it.